ProcessOne SiteCustomer Helpdesk and FeedbackFollow us on Twitter
 
   
 
PubSub not supported?
Posted: 04 July 2011 08:57 PM   [ Ignore ]
Newbie
Rank
Total Posts:  1
Joined  2011-07-04

Hi,

I installed ProcessOne ejabberd server under Windows 7 and it is running and I can connect to it with the admin account that was created during the installation process. Unfortunately, it doesn’t look like PubSub is supported (returning 501 feature not implemented), unless perhaps there is a setting I need to change to enable it? These are the commands my client is sending to the server and the responses received from the server:

Sent:

XMPP/Gloox (XML Out): <iq to=‘dominique7-pc’ id=‘uid:4e1209a2:000027b4’ type=‘get’ from=‘admin@dominique7-pc/26186170211309804963151002’ ><options node=‘http://jabber.org/protocol/nick’ jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub></iq>
XMPP/Gloox (XML Out): <iq to=‘dominique7-pc’ id=‘uid:4e1209a2:00002b96’ type=‘get’ from=‘admin@dominique7-pc/26186170211309804963151002’ ><options jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub></iq>
XMPP/Gloox (XML Out): <iq to=‘dominique7-pc’ id=‘uid:4e1209a2:0000065a’ type=‘get’ from=‘admin@dominique7-pc/26186170211309804963151002’ ><items node=‘http://jabber.org/protocol/nick’></pubsub></iq>
XMPP/Gloox (XML Out): <iq to=‘dominique7-pc’ id=‘uid:4e1209a2:00002442’ type=‘get’ from=‘admin@dominique7-pc/26186170211309804963151002’ ><items></pubsub></iq>
XMPP/Gloox (XML Out): <iq to=‘dominique7-pc’ id=‘uid:4e1209a2:00005ba1’ type=‘set’ from=‘admin@dominique7-pc/26186170211309804963151002’ ><subscribe node=‘http://jabber.org/protocol/nick’ jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub></iq>

Received:

XMPP/Gloox (XML In): <iq from=‘dominique7-pc’ to=‘admin@dominique7-pc/26186170211309804963151002’ type=‘error’ xml:lang=‘en’ id=‘uid:4e1209a2:000027b4’><options node=‘http://jabber.org/protocol/nick’ jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub><error code=‘501’ type=‘cancel’><feature-not-implemented ></error></iq>
XMPP/Gloox (XML In): <iq from=‘dominique7-pc’ to=‘admin@dominique7-pc/26186170211309804963151002’ type=‘error’ xml:lang=‘en’ id=‘uid:4e1209a2:00002b96’><options jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub><error code=‘501’ type=‘cancel’><feature-not-implemented ></error></iq>
XMPP/Gloox (XML In): <iq from=‘dominique7-pc’ to=‘admin@dominique7-pc/26186170211309804963151002’ type=‘error’ xml:lang=‘en’ id=‘uid:4e1209a2:0000065a’><items node=‘http://jabber.org/protocol/nick’></pubsub><error code=‘501’ type=‘cancel’><feature-not-implemented ></error></iq>
XMPP/Gloox (XML In): <iq from=‘dominique7-pc’ to=‘admin@dominique7-pc/26186170211309804963151002’ type=‘error’ xml:lang=‘en’ id=‘uid:4e1209a2:00002442’><items></pubsub><error code=‘501’ type=‘cancel’><feature-not-implemented ></error></iq>
XMPP/Gloox (XML In): <iq from=‘dominique7-pc’ to=‘admin@dominique7-pc/26186170211309804963151002’ type=‘error’ xml:lang=‘en’ id=‘uid:4e1209a2:00005ba1’><subscribe node=‘http://jabber.org/protocol/nick’ jid=‘admin@dominique7-pc/26186170211309804963151002’></pubsub><error code=‘501’ type=‘cancel’><feature-not-implemented ></error></iq>

Profile
 
 
Posted: 06 July 2011 07:45 AM   [ Ignore ]   [ # 1 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  605
Joined  2006-11-12

Did you enable pubsub in your config file ?

Profile