ProcessOne SiteCustomer Helpdesk and FeedbackFollow us on Twitter
 
   
 
esdl packaging and code don’t agree
Posted: 06 October 2011 11:11 PM   [ Ignore ]
Newbie
Rank
Total Posts:  1
Joined  2011-10-06

Just a bit ago I was trying to get setup to use esdl to write games using erlang.  So I downloaded and installed it from cean, and then tried to run sdl:init/1.

It failed, giving me the message:

Driver Failed {error,{open_error,-10}} 

after much futzing around, I discovered that what this cryptic error message actually means is:
“cannot open shared object file: No such file or directory”

Looking into it further, I discovered that the hierarchy of the esdl package was not what the code in the init function was expecting to find. 

My cean-created path to the sdl_driver.so was this:

esdl-0.96.0626/priv/linux-x86/lib/sdl_driver.so

but a cursory inspection of the code in sdl.erl revealed that it expected the .so file to be located directly inside priv/

The way that I fixed this issue was to modify the directory structure so that sdl_driver.so was located directly inside of priv/  Then everything worked just fine.

I couldn’t find any information about this issue, so I figured I’d post about it here to help other people out.

Profile
 
 
Posted: 14 November 2011 01:46 PM   [ Ignore ]   [ # 1 ]
Senior Member
Avatar
RankRankRankRank
Total Posts:  134
Joined  2006-11-13

this issue is fixed on latest CEAN 2.0 code. site upgrade in progress…

Profile